Back
Degraded

Server Issue with Hosted Provider
Started 20 Nov at 02:00pm EST, resolved 20 Nov at 03:35pm EST.
MultiTenant Database Services
Resolved
We identified the root cause of the issue with our hosted provider and have restored service to any impacted clients.
Posted 20 Nov at 03:35pm EST.

Created
Our hosted provider is currently experiencing an issue with one of our servers. We are actively engaged and troubleshooting the issue.
Posted 20 Nov at 02:00pm EST.